WordPress 2.8.3 Security Release

WordPress 2.8.3

Heads up for all WordPress users. Earlier today, the folks from WordPress released version 2.8.3, a security release that fixes some issues that were overlooked in version 2.8.1 and weren’t included in version 2.8.2. Here’s the word from the WordPress blog:

Unfortunately, I missed some places when fixing the privilege escalation issues for 2.8.1. Luckily, the entire WordPress community has our backs. Several folks in the community dug deeper and discovered areas that were overlooked. With their help, the remaining issues are fixed in 2.8.3.

One of the strengths of WordPress is having a very active and vigilant community that helps the developers in finding and fixing bugs and other issues in WordPress releases including WordPress themes or plugins and they all do it without any type of compensation or recognition. In behalf of myself and other WordPress users, thank you very much!

Btw, I already upgraded my installation to WordPress 2.8.3 and you should too. It only takes a few minutes of your time and it keeps your blog secure and safe. Like I always say, “better safe than sorry”.

Anyone else upgraded or plan to upgrade their installation to WordPress 2.8.3 later? Did you encounter any conflicts or issues during or after the upgrade? Please share your thoughts by leaving a comment below.

This post may contain affiliate links that allow us to earn commissions at no additional cost to you. We are reader-supported so when you buy through the affiliate links, you are also helping or supporting us. 

10 Comments

  1. @Blogspot – I was still on hiatus when WordPress 2.8 & 2.8.1 were released so I wasn’t able to know/read more about it, although I did experience problems with the plugin auto upgrade feature with version 2.8.2 which is the version I upgraded to from 2.7+.

    Anyways, hope you find a solution to fix the errors you’re experiencing A.S.A.P.

  2. Blogspot to Wordpresssays:

    The release of WordPress 2.8.3 was unexpected but looking at the no of bugs and error wordpress 2.8.1 and 2.8.2 had, It was much expected update. Though I updated WordPress to 2.8.3 and I can still see few Errors in my dashboard
    When Even I try to publish article from edit page option, it gives error.. Still waiting for wordpress forum to come up with the best solution..

  3. @Loy – Hehe..I know how it feels, happened to me several times before. Just upgraded my WordPress installation then a short time later, a newer version is released to patch up a bug or security flaw. But like I said earlier, I don’t mind it coz it means that WordPress is always updated and kept secure.

  4. @Michael – That’s one of the good things about WordPress, the community is very active. Bugs and security flaws get fixed quickly. I don’t mind doing frequent updates as long it keeps WordPress up-to-date and secure.

  5. @Dexter – Yes, its always better to practice safety first and to do preventive measures especially for us bloggers, coz we can lose everything in an instant if we’re not careful. :)

Leave a Reply

Your email address will not be published.

JaypeeOnline