WordPress 2.3 is gonna be released pretty soon but before you get all excited, there’s something you might want to know before you upgrade your WordPress installation. If you aren’t aware of it yet, this version has some plugin compatibility issues due to some schema changes that can result in breaking the plugins that you’re currently using.

WP 2.3 changes the database schema in 3 ways but the one with the biggest impact are the taxonomy related changes. What happened is that the development team decided to drop the categories, post2cat, and link2cat tables. This means that any plugin that use or require these tables will break.

In my case, there’s one particular plugin I’m using which is really important to my blog and is affected by this issue: the UTW or Ultimate Tag Warrior plugin. I hope the author would find a way to fix the problem or that the WordPress development team would make it easy for UTW users to import tags used by the plugin into the WordPress tagging system.

The WordPress community has started a list to help users and plugin authors to identify which plugins are working/compatible with WordPress 2.3 and which ones don’t or needs updating. To find out the compatibility of your current plugins, check out the WordPress 2.3 plugin compatibility list.

Btw, those of you who have been testing WordPress 2.3 Beta, you are encouraged to add to the plugins that you’re using and categorize them whether they work or needs work.

JaypeeOnline is supported by its audience. When you click on the advertisements or purchase through links on our site, we may earn an affiliate commission. Learn more

Share:

administrator

Owner and editor of JaypeeOnline. Self-proclaimed geek. New media writer and consultant. WordPress advocate. Loves blogging, gadgets, video games and sports. You can follow him on Facebook or Twitter.

28 Comments

  • JP Habaradas, September 20, 2007 @ 5:45 AM

    @Beng – You’re welcome! It’s good to know that you were able to recover your old posts and comments. :D

  • Beng, September 20, 2007 @ 5:35 AM

    re new themes – thank you. derived from fluidity ang dalawa doon. anyways, i am so buba talaga. nakalimutan kong may import option ang wordpress :mad: i moved my old installation na to the current one. so ngayon ay wala ng nasayang na post and comments. i was able to merge it!!! yuhooo.

  • JP Habaradas, September 19, 2007 @ 9:15 PM

    @Allen – Oh I see. I’ll send it to you via email later when I find the time, ok? Have a good weekend. :)

  • Allen, September 19, 2007 @ 9:02 PM

    Just for references. haha I like adding more plugins to my blog :twisted:

  • JP Habaradas, September 19, 2007 @ 5:36 PM

    @love – You’re welcome! :)

  • love, September 19, 2007 @ 5:08 PM

    thanks for the info jaypee… :)

  • JP Habaradas, September 19, 2007 @ 6:30 AM

    @christian – Oh okay. I thought you were referring to the current version, WordPress 2.2.3. It’s good to hear it from someone who actually tried it and that it actually works. :)

  • christian, September 19, 2007 @ 5:55 AM

    You see, I’ve tried the beta version of WP2.3. I tried the built in import of WP so I can use my tags that were created in UTW. And it works!

  • JP Habaradas, September 18, 2007 @ 9:30 PM

    @Allen – If you want, I can send it to you via email. Btw, what do you need it for? ;)

  • Allen, September 18, 2007 @ 9:04 PM

    Hmm Mr. Jaypee, Can i request that you make a post or a list of the wordpress plugins you use? :D Thanks.

  • JP Habaradas, September 18, 2007 @ 7:53 PM

    @christian – Which option do you use in the Import section? WordPress? From what I know, the built-in tagging system will be implemented starting with version 2.3.

  • christian, September 18, 2007 @ 7:12 PM

    There is way you can import your UTW tags to WP. It’s in the “Import” section of your WP admin.

  • JP Habaradas, September 18, 2007 @ 6:45 PM

    @Beng – Really? That sucks! Sayang naman yon mga old posts & comments mo. Do you have database backups? If you do, did you try to restore it using your backup?

    Btw, I just saw your recent theme releases. They all look good. Great job! :D

  • Beng, September 18, 2007 @ 6:38 PM

    don’t know what really happened. i was too busy with my studies that time kaya hindi ko ito talaga napagtunan ng pansin. fact is, that several post and comments got messed up. wala na ang mga ito sa tamang category. i can’t figure out what caused the problem, but i really don’t care about it anymore. ginawa ko nalang Kauderwelsch Archive ang lumang installation.

  • JP Habaradas, September 18, 2007 @ 6:30 PM

    @Mandy – Hehe is that so? Btw, what’s your blog url so I can go and pay a visit? You’re welcome and thanks for dropping by! :)

  • Mandy, September 18, 2007 @ 12:11 PM

    With all these updates all the time I think I spend more time upgrading then I do posting in my blog. Thanks for the info. :)

  • JP Habaradas, September 18, 2007 @ 8:00 AM

    @jhay – Yup, it’s that time again. But now, I’m not that worried anymore coz I know that WP 2.3 has a built-in importer for UTW tags.

    I forgot to mention another plugin I’m using that’s affected by the tagging issue: Extended Live Archives. I’ve already found a fix but haven’t tried it yet. Will try it out as soon as WP 2.3 is released. Something to look forward to and play with. Hehe :)

  • jhay, September 18, 2007 @ 7:28 AM

    Ah, here we go again with all the plugins breaking and whatnots with a new major release of WP.

    It’s time to double-check those plugins again.

  • JP Habaradas, September 18, 2007 @ 6:30 AM

    @Christine – That’s definitely good news for the many users of UTW. Thanks for the heads up and for taking the time to drop by! :)

  • Christine D., September 18, 2007 @ 6:25 AM

    WordPress 2.3 has a built in importer for importing UTW tags. Glee.

  • JP Habaradas, September 18, 2007 @ 6:00 AM

    @trench – Scared? Don’t be! I also love my plugins but I’m sure it won’t be long until the authors update them.

    Btw, which plugins are you using that’s not compatible with WP 2.3?

  • trench, September 18, 2007 @ 5:59 AM

    Im scared! LOL. Damn man! I love my plugins I have!

  • JP Habaradas, September 18, 2007 @ 4:00 AM

    @Beng – Don’t worry, even if I could I don’t have the answer to it. Hehe :D

    If you don’t mind me asking, what exactly happened during your upgrade? Was it because of a plugin?

  • Beng, September 18, 2007 @ 3:26 AM

    oh my goat! why do they keep on changing something everytime they make an upgrade. nope don’t answer this silly question of mine Jaypee :wink:

    i am luckily not using a plugin which is using queries to those tables you mentioned. i am bit careful at the moment due to my update experience to version 2.2 series. my site got messed up thus i decided to install my wp site in another database :cry:

  • JP Habaradas, September 18, 2007 @ 2:00 AM

    @Allen – Same here. I have another plugin that doesn’t work with 2.3, WP Useronline. You can look for alternative plugins but if I were you, just a while coz I’m sure most of the authors would update these plugins to work with 2.3. :)

  • Allen, September 18, 2007 @ 1:47 AM

    I’m quite excited on the release of wordpress 2.3. However, some of the plug ins I use have compatibility issues so I need to look for alternate plug ins first. haha ^_^

  • JP Habaradas, September 18, 2007 @ 12:13 AM

    @Joni – No it doesn’t. The tagging feature was supposed to be included in WP 2.2 but it didn’t make it on time for the release so it will be included in version 2.3.

    Btw, I think you got mixed up. What I’m talking about in this post is the coming WordPress 2.3 version and not 2.2.3. :)

  • Joni, September 17, 2007 @ 11:58 PM

    Hi Jaypee. Does version 2.2.3 have a built-in tagging feature similar to UTW? I can't find it in my dashboard. I must be searching in vain. Heh.

    Good thing my plugins weren't affected by the upgrade. :)

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.