Ultimate Tag Warrior + WP 2.1 = Lost Tags



If you’re using the latest version of Ultimate Tag Warrior and plan to upgrade to WordPress 2.1, don’t!

While I was looking for a fix for my trackback problem, I found out that using Ultimate Tag Warrior version 3.141592 with WordPress 2.1 will cause you to lose all your tags on a post whenever a new comment is added, deleted, or unapproved. I was guilty of using both so I checked my recent posts after the WordPress upgrade and true enough, my tags were all gone. I had to add all the tags back for each post.

Ultimate Tag Warrior is a very good plugin however, the current version doesn’t work with WordPress 2.1. This issue has already been verified as a bug and expect to see an update.

In the meantime, if you’re also a victim of this don’t fret. Moeffju has a manual fix for it. Below is the steps on how to do it.

How to fix it:

1. In the UTW folder look for: -actions.php & -actions-wordpress2.php.
2. Open both files with your text editor.
3. Look for function ultimate_save_tags($postID).
(-actions.php go to line 499 and -actions-wordpress2.php go to line 424).
4. Right after the curly bracket “{“, insert these lines:

if (!is_admin()) return $postID;
if (!isset($_POST[‘tagset’])) return $postID;

5. Save the files, upload them via FTP & overwrite existing files.

That should fix the problem. I also did this and so far it has solved the issue.

If you would like to try another plugin to work with your tags, another option is to use Bunny’s Technorati Tags.

Owner and editor of JaypeeOnline. Self-proclaimed geek. New media writer and consultant. WordPress advocate. Loves blogging, gadgets, video games and sports. You can follow him on Google+, Facebook or Twitter.

7 Comments

  1. Jaypee

    January 31, 2007 at 10:23 AM

    @milo – Yeah, there are a few but not all blogs have the same problems. There were a few minor issues I had to fix but everything's working fine right now. But if you wantto play safe, then just wait til every bug gets fixed. Yup, read the email and sent you a reply. Thanks! :)

  2. milo

    January 31, 2007 at 9:26 AM

    I've read some bad issues with WP 2.1, better wait til it's fixed.

    Btw: shot a mail about themes.

  3. Jaypee

    January 30, 2007 at 8:32 AM

    @iskoo – Buti na lang! Hehe

    Btw, have you upgraded to 2.1 already?

  4. iskoo

    January 29, 2007 at 9:05 PM

    buti nalang nabasa ko ito, kaka download ko lang wp 2.1

  5. Jaypee

    January 29, 2007 at 1:52 AM

    @jhay – Yeah, I didn't even know about the bug til now and good thing that it wasn't too late. If not, I'd be retyping all those tags back to each post. Hehe :P

    @nevins – Yeah, good to see someone I actually know here in the blogosphere. Hehe :D

  6. nevins

    January 28, 2007 at 9:31 PM

    bro, nice to c you around! :)

    regards for my sist and my nephew… hehehhe.

    i have added your blog on my roll 2. :)

  7. jhay

    January 28, 2007 at 11:33 AM

    Nice, I've been looking for a fix for the UTW bug. I'll test this on my sandbox, thinking I'll just for the official fix release, besides the Cutline theme is not yet fully compatible with WP 2.1 Oh wel…

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.